How not to update your Xcode while you still want to run projects on latest iOS version

Deja vu?

How it’s happened?

I haven’t use real device to test my project since I update my iOS version over 15, but the problem need to use real device is really annoying me, so I can’t just run away from this problem, I try to restart my phone/Xcode/Macbook, then I found a article said it might be the version problem, so that’s the whole journey begins…

Trigger Criteria

If when your iOS version isn’t match your Xcode support device🤷🏻‍♂️

My situation

  • iOS Version → 15.4.1
  • Xcode Version → 13

Solution

  1. You can enter Window → Devices and Simulators to check your connection status
normally here you can see the problem then search for solution
As the scenario, you need to update Xcode to 13.3 to support 15.4 real device

--

--

Get the Medium app

A button that says 'Download on the App Store', and if clicked it will lead you to the iOS App store
A button that says 'Get it on, Google Play', and if clicked it will lead you to the Google Play store